Fentrica - Email Delivery Delays (SendGrid) – Incident details

All systems operational

Email Delivery Delays (SendGrid)

Resolved
Degraded performance
Started 15 days agoLasted 42 minutes

Affected

Building Digitalization Suite

Degraded performance from 3:17 PM to 3:59 PM

Mantis

Degraded performance from 3:17 PM to 3:59 PM

Messaging

Updates
  • Resolved
    Resolved

    This incident has been resolved. Due to a significant traffic spike, our service provider temporarily held some emails for additional spam inspection. The provider has now adjusted their thresholds, and email delivery has returned to normal.

  • Investigating
    Investigating

    We are currently observing delays in transactional email delivery. We are actively monitoring the situation and will post updates as soon as more information is available